[Linux] Perte du seul disque système et le système est opérationnel

vendredi 17 février 2012
par  Jerome ROBERT
popularité : 5%

Perte du seul disque système et le système est opérationnel

 !! Ce n’est pas un blague !!

Après un incident de bloc d’alimentation du serveur, arrêt brutal du serveur et j’ai perdu la partition /home.

Et après quelque commande ci-dessous, j’avais l’impression d’avoir aussi perdu le disque système.

# df
Sys. de fichiers 1K-blocs Utilisé Dispo. Uti% Monté sur
/dev/sda1 5162796 2568344 2332196 53% /
tmpfs 489868 0 489868 0% /lib/init/rw
udev 10240 36 10204 1% /dev
tmpfs 489868 0 489868 0% /dev/shm



# mount -a
mount : special device /dev/sda2 does not exist

#ls /dev/sda2
ls : impossible d’accéder à /dev/sda2 : Aucun fichier ou dossier de ce type


#ls /dev/sda1
ls : impossible d’accéder à /dev/sda1 : Aucun fichier ou dossier de ce type

# fdisk -l ==> rien ... pas de disque

Le système est UP, sur le disque que le système ne retrouve plus...
 



# more /proc/partitions
major minor #blocks name

 8 0 244198584 sda
 8 1 5245191 sda1
 8 2 238428697 sda2
 8 3 522112 sda3


Création des fichiers spéciaux à l’ancien

# mknod /dev/sda b 8 0
# mknod /dev/sda1 b 8 1
# mknod /dev/sda3 b 8 3
 

 

Chargement des informations du disque au kernel

# partx -a /dev/sda
BLKPG : Device or resource busy
error adding partition 1
BLKPG : Device or resource busy
error adding partition 2
BLKPG : Device or resource busy
error adding partition 3

# mount -a
# df
Sys. de fichiers 1K-blocs Utilisé Dispo. Uti% Monté sur
/dev/sda1 5162796 2568320 2332220 53% /
tmpfs 489868 0 489868 0% /lib/init/rw
udev 10240 36 10204 1% /dev
tmpfs 489868 0 489868 0% /dev/shm
/dev/sda2 234685816 84665072 138099312 39% /home


Magique /home est de retour ...
 


Statistiques

Dernière mise à jour

mercredi 5 juillet 2017

Publication

264 Articles
Aucun album photo
Aucune brève
6 Sites Web
2 Auteurs

Visites

9 aujourd’hui
186 hier
523651 depuis le début
5 visiteurs actuellement connectés